Excel par l'exemple
Débuter et progresser sur Microsoft Excel à l'aide d'exercices aidés et corrigés, de guides pratiques, de trucs et astuces, d'un forum utilisateurs, etc.

 


Accueil
Guides Excel
Excel en Vidéos
Formules de calcul
Exercices
Raccourcis Clavier
Trucs et Astuces
Applications
Forum Utilisateurs
Ancien Forum
Liens Utiles
Livre d'Or
Contact

=SOMME()
=SOMME.SI()
=SOMME.SI.ENS()
=SOMMEPROD()
=MOYENNE()

=ARRONDI()
=ARRONDI.INF()
=ARRONDI.SUP()
=ARRONDI.AU.MULTIPLE ()
=MAX()
=MIN()
=GRANDE.VALEUR()
=PETITE.VALEUR()

NB : N'oubliez pas que vous pouvez combiner ces fonctions entre elles. Par exemple vous pouvez avoir :

=somme(A1:F4)+max(B2:H28)+petite.valeur(B16:K20)


La fonction =SOMME()

Pour additionner entre elles plusieurs cellules contiguës, on peut utiliser la fonction SOMME d’EXCEL.

  • Ecrire dans la cellule où doit apparaître le résultat : =somme(

  • Sélectionner ensuite à la souris la plage de cellules à additionner.

  • Valider avec la touche Entrée

La fonction renvoie l’addition des sommes sélectionnées.

Exemple :

  • En A5 on écrit la formule suivante :

=SOMME(A1:A4)

Le résultat donne : 31


La formule =SOMME.SI()

Cette fonction vous permet d'additionner plusieurs cellules en fonction d'un critère déterminé.

Voici sa syntaxe :

=SOMME.SI(plage;critère;somme_plage)

plage est la plage de cellule contenant le critère à retenir

critère est LE critère à retenir (chiffre ou texte)

somme_plage est la plage de cellule où se trouvent les nombres à additionner.

Exemple : Dans la colonne A on a écrit des nombres. En colonne B, on a indiqué "garçon" ou "fille". On voudrait obtenir le total des nombres de la colonne A auxquels correspondent le mot "fille" en colonne B.

  • En A7 on écrit la formule suivante :

=SOMME.SI(B1:B6;"fille";A1:A6)

Le résultat donne : 66


La formule =SOMME.SI.ENS()

 

Cette formule permet d'additionner plusieurs cellules en fonction de plusieurs critères.

Voici sa syntaxe :

=SOMME.SI.ENS(Plage_somme ;Plage_critères1;Critères1;[plage_critères2;critères2];….)

Exemple :

Ici :

·    Plage_somme, la plage de cellule contenant les montant à additionner, (dans la formule D:D),

·    Première page de critères ; la colonne du service, la colonne C (dans la formule C:C),

·     Premier critère, le service saisi en cellule G1,

·     Deuxième plage de critères, la colonne du sexe, la colonne B (dans la formule B:B),

·     Deuxième critère, le sexe saisie en cellule F2,

 


La formule =SOMMEPROD()

Réalisation d'opérations conditionnelles comptant et additionnant en utilisant des conditions multiples

Les formules permettant de calculer le nombre de valeurs ou les sommes sont fondées sur deux conditions ou plus.

La fonction que nous allons utiliser est SOMMEPROD ; celle-ci appartient à la catégorie Math & Trigo.

Exemple : Compter le nombre de mois où un commercial fait une vente. Le tableau de départ pourrait se présenter sous cette forme :

Exemple 1 : Compter le nombre des ventes faites par Jules sur le mois de février.

C'est une formule conditionnelle qui emploie deux conditions.

= SOMMEPROD((A2:A13="Jules")*(B2:B13="Février"))

Résultat de formule: 2


Exemple 2 : Compter les mois où les ventes sont plus grandes qu'une quantité spécifique

Vous pouvez employer une formule semblable à celle ci-dessus pour travailler avec des données numériques. Cette formule renvoie le nombre de lignes pour lesquelles le mois est égal à janvier et le montant est supérieur à 200.

= SOMMEPROD((B2:B13="Janvier")*(C2:C13>200))

Résultat de formule: 5


Exemple 3 : Compter le nombre de ventes comprises entre certaines valeurs spécifiques

Cette formule compte le nombre de fois où les ventes sont comprises entre 200 et 500. La formule emploie deux conditions : la quantité supérieure ou égale à 200, et la quantité inférieure ou égale à 500.

=SOMMEPROD((C2:C13>=200)*(C2:C13<=500))

Résultat de formule: 6


Exemple 4 : Compter le nombre de ventes basées sur trois conditions

Cette formule renvoie le nombre de fois où le commercial est Jules, le mois est février, et la quantité est supérieure à 500. Cette fonction emploie un argument simple, qui se compose de trois expressions logiques multipliées les unes aux autres.

=SOMMEPROD((A2:A13="Jules")*(B2:B13="Février")*(C2:C13>500))

Résultat de formule: 1


Exemple 5 : Totaliser les ventes d'un commercial pour un mois donné

La formule calcule la somme des ventes basée sur deux conditions : quand le commercial est Jules et le mois est février.

=SOMMEPROD((A2:A13="Jules")*(B2:B13="Février")*(C2:C13))

Résultat de formule: 1150


Exemple 6 : Totaliser les ventes combinées pour deux commerciaux

La formule ci-dessous renvoie la somme des ventes pour Jules et Pascal. Cette formule emploie un argument simple et se compose de trois expressions.

=SOMMEPROD(((A2:A13="Jules")+(A2:A13="Pascal"))*(C2:C13))

Résultat de formule: 2585

Attention : les deux premiers arguments ne sont pas multipliés comme dans les exemples précédents. Dans la mesure où nous réalisons un test logique " OU ", ils sont additionnés. Addition de deux résultats logiques de valeur 1 quand l'une ou l'autre des expressions est VRAIE.


La fonction =MOYENNE()

Pour obtenir la moyenne de plusieurs cellules contiguës, on peut utiliser la fonction MOYENNE d’EXCEL.

  • Ecrire dans la cellule où doit apparaître le résultat : =moyenne(
  • Sélectionner ensuite à la souris la plage de cellules désirée
  • Valider avec la touche Entrée.

La fonction renvoie la moyenne des sommes sélectionnées

Exemple : Dans la colonne A on a écrit des nombres. On voudrait obtenir la moyenne des nombres de la colonne A.

  • En A7 on écrit la formule suivante :

=MOYENNE(A1:A6)

Le résultat donne : 26


La formule =ARRONDI()

 Le résultat d’une division ou d’une multiplication peut donner un nombre comportant plusieurs décimales. Dans le but de créer des formulaires destinés à des tiers (exemple facture) les nombres doivent, en principe, se présenter avec simplement deux décimales. On peut, bien entendu, utiliser le format des nombres. Mais Excel va conserver en mémoire le nombre initial avec plusieurs décimales et l’utilisera pour les calculs ultérieurs. D’où des problèmes d’affichages.

Exemple :

Le résultat du calcul : 2 divisé par 3 donne le résultat 0.666666666.....

Si on additionne 0.66666666.... avec 0.6666666.... on obtient 1.33333333.....

 

 

Avec un format des nombres à deux décimales, Excel propose un arrondi de présentation qui donnera : 0.67 + 0.67 = 1.33. Evidemment, cet arrondi de présentation n’est pas satisfaisant. Il faut donc utiliser une formule d’EXCEL, la formule ARRONDI()

Voici sa syntaxe :

=ARRONDI(nombre;No_chiffres)

Cette formule requiert deux arguments :

  • nombre est le nombre à arrondir. Ce nombre peut également être remplacé par la référence à une cellule contenant un nombre. Il peut également être une formule de calcul complexe.
  • No_chiffres représente le nombre de décimales que l’on souhaite obtenir.

On aura donc par exemple pour obtenir le résultat du calcul 2/3 arrondi à 2 décimales:

=ARRONDI(2/3;2)

Le résultat de cette formule sera 0.67. Ce nombre s’affichera directement dans la cellule sans que l’on ait besoin de passer par le format des nombres.

L’argument "nombre de décimales " donne des arrondis différents selon le chiffre utilisé. Voici un exemple des arrondis possibles du nombre 10734,12 :

ARRONDI(10734,12;2) 10734.12
ARRONDI(10734,12;1) 10734.1
ARRONDI(10734,12;0) 10734
ARRONDI(10734,12;-1) 10730
ARRONDI(10734,12;-1,5) 10735
ARRONDI(10734,12;-2) 10700
ARRONDI(10734,12;-3) 11000
ETC.  

La fonction =ARRONDI.INF()

Pour obtenir un nombre arrondit tendant vers 0 (zéro).

Voici sa syntaxe :

=ARRONDI.INF(nombre;no_chiffres)

nombre représente un nombre réel quelconque à arrondir en tendant vers zéro.

no_chiffres  représente le nombre de chiffres à prendre en compte pour arrondir l'argument nombre.

La fonction =ARRONDI.INF est similaire à la fonction ARRONDI, excepté qu'elle arrondit toujours le nombre en tendant vers zéro.

Si l'argument no_chiffres est supérieur à 0 (zéro), le nombre est arrondi à la valeur entière immédiatement inférieure (ou supérieure pour les nombres négatifs) et comporte le nombre de décimales spécifié.

Si l'argument no_chiffres est égal à 0, le nombre est arrondi au nombre entier immédiatement inférieur.

Si l'argument no_chiffres est inférieur à 0, le nombre est arrondi à la valeur immédiatement inférieure (ou supérieure si négative) par incrémentations de 10, 100, etc., en fonction de la valeur de no_chiffres.

Exemple

 

Formule

Description (résultat)

=ARRONDI.INF(3,2;0)

Arrondit 3,2 à la valeur entière immédiatement inférieure (3)

=ARRONDI.INF(76,9;0)

Arrondit 76,9 à la valeur entière immédiatement inférieure (76)

=ARRONDI.INF(3,14159;3)

Arrondit 3,14159 à la valeur inférieure comportant trois décimales (3,141)

=ARRONDI.INF(-3,14159;1)

Arrondit -3,14159 à la valeur inférieure comportant une décimale (-3,1)

=ARRONDI.INF(31415,92654;-2)

Arrondit 31415,92654 à gauche du séparateur décimal, à la centaine immédiatement inférieure (31400)

 


La fonction =ARRONDI.SUP()

Pour obtenir le plus grand nombre contenu dans des cellules différentes, on peut utiliser la fonction MAX() d’EXCEL.

Voici sa syntaxe :

=MAX(plage_de_cellules)

plage_de_cellules est la zone dans laquelle la valeur la plus élevée doit être cherchée.

  • Ecrire dans la cellule où doit apparaître le résultat : =max(

  • Sélectionner ensuite à la souris la plage de cellules (ou plusieurs plages de cellules en maintenant la touche Ctrl enfoncée) désirée.

  • Valider avec la touche Entrée

la fonction renvoie la valeur la plus élevée


La fonction =MIN()

Pour obtenir le plus petit nombre contenu dans des cellules différentes, on peut utiliser la fonction MIN() d’EXCEL.

Voici sa syntaxe :

=MIN(plage_de_cellules)

plage_de_cellules est la zone dans laquelle la valeur la moins élevée doit être cherchée.

  • Ecrire dans la cellule où doit apparaître le résultat : =min(

  • Sélectionner ensuite à la souris la plage de cellules (ou plusieurs plages de cellules en maintenant la touche Ctrl enfoncée) désirée.

  • Valider avec la touche Entrée

la fonction renvoie la valeur la moins élevée

 

Pour obtenir le plus petit nombre contenu dans des cellules différentes, on peut utiliser la fonction MIN() d’EXCEL.

  • Ecrire dans la cellule où doit apparaître le résultat : =min(
  • Sélectionner ensuite à la souris la plage de cellules (ou plusieurs plages de cellules en maintenant la touche Ctrl enfoncée) désirée.
  • Valider avec la touche Entrée

 

la fonction renvoie la valeur la moins élevée


La fonction =GRANDE.VALEUR()

Pour obtenir le plus petit nombre contenu dans des cellules différentes, on peut utiliser la fonction GRANDE.VALEUR() d’EXCEL.

Voici sa syntaxe :

=GRANDE.VALEUR(plage_de_cellules;rang à prendre en compte)

plage_de_cellules est la zone dans laquelle la valeur doit être cherchée.
rang à prendre en compte est le nombre correspondant au rang de la valeur cherchée. Si vous écrivez 3 la fonction cherchera la 3eme plus grande valeur de la plage_de_cellules.

  • Ecrire dans la cellule où doit apparaître le résultat : =grande.valeur(

  • Sélectionner ensuite à la souris la plage de cellules (ou plusieurs plages de cellules en maintenant la touche Ctrl enfoncée) désirée.

  • écrivez ; (point virgule) puis le rang souhaité

  • Valider avec la touche Entrée

la fonction renvoie la valeur souhaitée

 


La fonction =PETITE.VALEUR()

Pour obtenir le plus petit nombre contenu dans des cellules différentes, on peut utiliser la fonction PETITE.VALEUR() d’EXCEL.

Voici sa syntaxe :

=PETITE.VALEUR(plage_de_cellules;rang à prendre en compte)

plage_de_cellules est la zone dans laquelle la valeur doit être cherchée.
rang à prendre en compte est le nombre correspondant au rang de la valeur cherchée. Si vous écrivez 3 la fonction cherchera la 3eme plus petite valeur de la plage_de_cellules.

  • Ecrire dans la cellule où doit apparaître le résultat : =petite.valeur(

  • Sélectionner ensuite à la souris la plage de cellules (ou plusieurs plages de cellules en maintenant la touche Ctrl enfoncée) désirée.

  • écrivez ; (point virgule) puis le rang souhaité

  • Valider avec la touche Entrée

la fonction renvoie la valeur souhaitée