Excel par l'exemple

Débuter et progresser sur Microsoft Excel à l'aide d'exercices aidés et corrigés, de guides pratiques, de trucs et astuces, d'un forum utilisateurs, etc.

EXCEL XP - Niveau 1

Téléchargez ce livret ici


 

L’utilisation des menus

 

Microsoft Office personnalise automatiquement les menus et barres d'outils en fonction de la fréquence d'utilisation des commandes. Lorsque vous lancez un programme Office pour la première fois, seules les commandes de base apparaissent. Puis, à mesure que vous travaillez, les menus et barres d'outils s'adaptent de sorte que seuls apparaissent les commandes et boutons de barre d'outils que vous utilisez le plus souvent.

 

Pour obtenir les options non disponibles, amenez simplement votre souris sur la partie basse du menu, celui-ci s’affichera avec toutes les options.

 

 

 

Lorsque vous cliquez sur une commande du menu développé, celle-ci est immédiatement ajoutée à la version courte du menu. Si vous n'utilisez pas souvent la commande, elle est retirée de la version courte du menu.

 

 

Le classeur

 

Chaque fichier Excel est représenté par un classeur comportant par défaut 3 feuilles. C’est ce classeur qui sera sauvegardé. Le nom et le nombre de feuilles qui le composent sont variables

 

Renommer les feuilles du classeur

 Par défaut, les feuilles du classeur porte le nom Feuil1, Feuil2, etc. Pour leur donner un nom plus explicite, on effectue un double clic sur l’onglet qui les désignent. Une boîte de dialogue s’ouvre alors dans laquelle on va saisir le nouveau nom.

 

Supprimer des feuilles d’un classeur.

 On effectue un clic à l’aide du bouton droit de la souris et on choisi l’option « supprimer ».

 

Ajouter des feuilles dans un classeur

 On effectue un clic à l’aide du bouton droit de la souris et on choisi l’option « insérer ». Dans la boîte de dialogue qui s’ouvre on choisi « feuille ».

 

Déplacer des feuilles dans un classeur

 A l’aide de la souris, on fait glisser l’onglet de la feuille à déplacer vers sa nouvelle position.

 

Déplacer ou copier des feuilles d’un classeur vers un autre classeur

 On effectue un clic à l’aide du bouton droit de la souris et on choisi l’option « déplacer ou copier ». La boîte de dialogue suivante s’ouvre :

 

On choisi le nom du classeur vers lequel les feuilles doivent être déplacées ou copiées (ce classeur doit être ouvert).

S’il s’agit d’effectuer une copie de la feuille, on clique sur l’option « Créer une copie » pour l’activer.

 

 

 

SAISIE ET MISE EN FORME


 

 

Recopie vers le Bas et vers la Droite.

 Cette fonction permet de recopier le contenu et le format d'une cellule vers une ou plusieurs cellules situées soit à droite soit à gauche de celle-ci.

 

Exemple pour recopier une cellule dans trois cellules vides se trouvant sur les lignes suivantes :

 

1)     Cliquer sur la cellule à recopier et sans relâcher le bouton de la souris, étendre la sélection aux trois cellules vides.

2)     Relâcher le bouton de la souris.

3)     La plage de cellules ainsi sélectionnée comporte une cellule en blanc (la cellule à recopier) et trois cellules en noir (les cellules sur lesquelles sera effectuée la recopie).

4)     ensuite le menu Edition - Remplissage - En Bas.

 

Alignement

 Par défaut les alignements sont les suivants :

 

Pour le texte : Alignement sur le bord gauche de la cellule

Pour les nombres : alignement sur le bord droit de la cellule

 

Il est possible de modifier cet alignement par défaut à l'aide des trois outils à disposition dans la barre d'outils :

 

Ces outils fonctionnent de la manière suivante :

 

 Aligne le contenu de la cellule sur le bord gauche de la cellule.

 Centre le contenu de la cellule par rapport aux bords gauche et droit de la cellule.

 Aligne le contenu de la cellule sur le bord droit de la cellule.

 

 

Fusionner des cellules

 Il est possible de fusionner des cellules horizontalement ou verticalement. Cette option permet, notamment, d’aligner les titres d’un tableau :

 

1)     Sélectionner, au clavier ou à la souris, les cellules à fusionner,

2)     Cliquer sur l’outil

 


 

 

Encadrement

 Le quadrillage de la feuille de calcul EXCEL n'est pas normalement destiné à être imprimé. Il convient donc procéder à l'encadrement des tableaux. Cette opération s'effectue après avoir sélectionné la partie à encadrer, en utilisant  le menu Format - cellule - onglet Bordure.

 

La boîte de dialogue est divisée en quatre parties :

 

·      La première partie (Bordure) sert à indiquer le bord de la cellule sur lequel le cadre sera tracé.

·      La seconde (style) détermine le style de trait à utiliser.

·      La troisième (couleur) la couleur à donner au style de trait choisi.

·      Une quatrième proposant directement de tracer un contour, des séparations intérieures ou d’annuler un quadrillage.

 

 

1)   On choisit tout d'abord la couleur du trait (« automatique » donne un trait noir quand le fond est blanc),

2)   On clique ensuite sur le style de trait désiré,

3)   On clique enfin sur le bord sur lequel apparaîtra le trait. Pour cela on agit,

Ø                    Soit directement sur le cadre aperçu (zone blanche)

Ø                    Soit sur les icônes au pourtour de l’aperçu.

 

Dans la barre d’outil on peut utiliser directement les options présélectionnées :


 

Largeur des Colonnes

 La largeur des colonnes est modifiable à l'aide du menu Format - colonne  - Largeur.

 

Pour modifier la largeur de la (ou des) colonne (s) sélectionnée(s), on écrit dans la zone « Largeur de colonne » le chiffre désiré.

 

Les autres opérations possibles sur la largeur des colonnes sont les suivantes :

 

·      Pour ajuster la largeur d'une colonne sur le contenu d'une cellule, on sélectionne tout d'abord la cellule en question et on utilise ensuite le menu Format - colonne  - Ajustement automatique.

·      On peut également faire disparaître à l'écran et à l'impression une colonne en utilisant le menu Format - colonne  - Masquer.

·      On la fera ensuite réapparaître en en utilisant le menu Format - colonne  - Afficher.

·      On peut enfin définir une nouvelle largeur standard pour les colonnes en modifiant le chiffre se trouvant dans la zone « Largeur standard ».

 

 

Il est également possible d'agir sur la largeur des colonnes à l'aide de la souris. Pour cela, on amène le curseur dans l'en-tête de colonne, sur le trait qui sépare la colonne à modifier de la suivante :

 

 

Le curseur prend l'aspect d'une double flèche. On peut alors agir sur la largeur de la colonne en maintenant cliqué le bouton gauche de la souris et en la faisant glisser à droite pour agrandir la colonne, à gauche pour la réduire. La nouvelle largeur de la colonne s'inscrit alors dans la partie gauche de la barre de formule. On peut également ajuster la largeur de la colonne sur son contenu le plus large en opérant un double clic à cet endroit.

 

Hauteur des Lignes

 La hauteur des lignes est modifiable à l'aide du menu Format - hauteur de ligne.

 

 

·      Pour modifier la hauteur de la (ou des) ligne (s) sélectionnée(s), on écrit dans la zone "Hauteur de ligne" le chiffre désiré.

 

Les autres opérations possibles sur la largeur des lignes sont les suivantes :

 

·      Pour ajuster la hauteur d'une ligne sur le contenu d'une cellule, on sélectionne tout d'abord la cellule en question et on utilise ensuite le menu Format - ligne  - Ajustement automatique.

 

·      On peut également faire disparaître à l'écran et à l'impression une ligne en utilisant le menu Format - ligne  - Masquer.

 

·      On la fera ensuite réapparaître en en utilisant le menu Format  - Afficher.

 

 

Il est également possible d'agir sur la hauteur des lignes à l'aide de la souris. Pour cela, on amène le curseur dans l'en-tête de ligne, sur le trait qui sépare la ligne à modifier de la suivante :

 

 

Le curseur prend l'aspect d'une double flèche. On peut alors agir sur la hauteur de la ligne en maintenant cliqué le bouton gauche de la souris et en la faisant glisser vers le bas pour agrandir la ligne, vers le haut pour la réduire. La nouvelle hauteur de la ligne s'inscrit alors dans la partie gauche de la barre de formule. On peut également ajuster la hauteur de la ligne sur son contenu le plus large en opérant un double clic à cet endroit.


 

 

Boutons Gras Italique

 Pour modifier rapidement l'aspect des caractères on dispose dans la barre d'outils d'un outil de mise en gras   et un outil de mise en italique .

 

Pour utiliser ces outils :

 

1)   Sélectionner la ou les cellules à modifier.

2)   Cliquer sur l'outil désiré.

 

 

Utiliser les motifs

 Pour mettre en évidence certaines zones de votre tableau (en-tête, totaux,...) ou en occulter d'autres (zones grisées,...), on peut remplir le fonds des cellules avec des motifs.

 

1)   Sélectionner la zone désirée.

2)  Choisir le menu Format - cellule - onglet Motif.

 

 

En mode noir et blanc, il est préférable de n’utiliser que la zone « Motifs ».

 

En cliquant sur la flèche à droite de la zone « Motif », on déroule la liste des motifs disponibles. Il faut choisir un motif clair pour des cellules contenant du texte. Il est préférable de mettre en gras le texte des cellules supportant un motif, même très clair.

   

Polices de caractères

 Il existe plusieurs formes de caractères sous Windows et donc EXCEL. Chacune de ces polices présente des styles différents (normal, gras, italique, gras et italique) ainsi que des tailles de caractères différentes. Afin d'agrémenter le document on pourra choisir des polices différentes pour les titres, les nombres, etc.

 

1)   Sélectionner les cellules à mettre en forme.

2)   Choisir le menu Format - cellule onglet police.

3)   La boîte de dialogue suivante s'ouvre :

 

 

 

C’est également dans cette boîte de dialogue que sera demandé le soulignement (disponible également dans la barre d’outils standard) et la couleur des caractères).

 

Ces modifications de police sont également accessibles à partir de la barre d’outils :

 

  

Sélections multiples

 Afin d'accélérer la mise en forme d'un document, il est possible de sélectionner sen même temps plusieurs cellules ou plages de cellules non contiguës.

Pour cela on procède de la façon suivante:

On sélectionne une première cellule ou plage de cellules.

On appuie ensuite sur la touche Ctrl du clavier.

On maintient cette touche Ctrl enfoncée et on effectue les autres sélections désirées, et ce, impérativement à la souris, en relâchant le bouton gauche à chaque fin de sélection.

Quand toutes les sélections sont terminées, on relâche la touche Ctrl.

  

Recopier des cellules

 Pour dupliquer une cellule ou un groupe de cellules, on va suivre la procédure suivante :

 

1)   Sélectionner la cellule ou le groupe de cellules à dupliquer.

2)   Choisir le menu Edition - Copier (ou la combinaison de touches Ctrl - C).

3)   Sélectionner la cellule où la sélection va être dupliquée.

4)   Choisir le menu Edition - Coller (ou la combinaison de touches Ctrl - V).

5)   On dispose à présent de deux zones identiques. Le contenu et le format des cellules des deux zones sont identiques et modifiables.

 

Modifier le contenu d'une cellule

 On distingue deux façons de procéder répondant à deux types d'actions différents. Dans les deux cas, on commence par sélectionner la cellule à modifier.

Remplacement complet du contenu de la cellule.

On retape alors directement le nouveau contenu qui va se substituer à l'ancien.

Correction d'une erreur de syntaxe ou d'une faute d'orthographe.

Il est dans ce cas inutile de retaper tout le contenu de la cellule. On intervient alors directement dans la barre de formule. Pour cela soit on clique dans la barre de formule à l'aide de la souris, soit on appuie sur la touche F2 du clavier. On se délace ensuite dans la barre de formule à l'aide des flèches du clavier, et on effectue les modifications nécessaires.

  

Effacer des cellules

 En cas d'erreur, on peut décider d'effacer le contenu ou le format d’une ou plusieurs cellules. Cette opération peut être réalisée de deux façons différentes :

 

Effacer uniquement le contenu de la (ou des) cellule(s)

Dans ce cas seul le contenu (texte saisi, formule de calcul) sera effacé.

1)     Sélectionner la ou les cellules pour lesquelles ont veut effacer le contenu.

2)     Appuyer sur la touche « SUPPR » du clavier.

 

Effacer uniquement le format de la (ou des) cellule(s)

Dans ce cas seul le format (motifs, format des nombres, encadrement,...) sera effacé.

1)     Sélectionner la ou les cellules pour lesquelles ont veut effacer le contenu.

2)     Choisir le menu Edition - effacer - format

 

Effacer tout (format et formules) de la (ou des) cellule(s)

Dans ce cas toute la (ou les) cellules(s) sera effacé.

1)     Sélectionner la ou les cellules pour lesquelles ont veut effacer le contenu.

2)     Choisir le menu Edition- effacer - tout.

 

 

Format des nombres

 ar défaut, les nombres sont en format standard. Une boîte de dialogue accessible par le menu Format - cellule - onglet Nombre permet de leur donner la présentation voulue. Parmi tous les formats proposés, on retrouve des constantes. Le tableau suivant récapitule les principaux formats à retenir :

 

Saisie au clavier

Standard

0

0.00

# ##0

# ##0.00

12

12

12

12.00

12

12.00

137.1

137.1

137

137.10

137

137.10

1528.45

1528.45

1528

1528.45

1 528

1 528.45

 

Il est à noter que les deux derniers formats affichent un espace afin de séparer les milliers des centaines.

 

A partir de ces différents formats de base, on trouve par exemple :

Ø      Le format monétaire : # ##0.00 € qui donne pour 10845 : 10 845 €

Ø      Le format pourcentage : 0.00% qui donne pour 12.25 : 12.25%

 

Format de la date

 Les dates dans EXCEL se saisissent de la façon suivante : JJ/MM/AA.

 

On peut néanmoins les présenter de différentes manières. Pour modifier le format de la date, on va utiliser, comme pour les nombres, le menu Format - nombres. Dans la catégorie date on choisira le format désiré sachant qu'il est possible de créer son propre format en le saisissant directement dans la zone code. On accède à cette zone en cliquant dedans. Les résultats des différents formats de dates choisis ou créés sont les suivants :

 

Format choisi

Résultat dans la cellule

Exemple de saisie initiale au clavier

4/7/94

J

4

JJ

04

JJJ

LUN

JJJJ

LUNDI

JJJJ J

LUNDI 4

M

7

MM

07

MMM

JUL

MMMM

JUILLET

AA

94

AAAA

1994

JJJJ J MMMM AAAA

LUNDI 4 JUILLET 1994

 

En partant des exemples ci-dessus, il est évidemment possible de créer le format de date de votre choix.

 

Renvoi à la ligne automatique

 Lors de la mise en page d'un tableau, le texte contenu dans une cellule peut ne pas tenir dans la largeur de celle-ci. Dans ce cas, il va s'étaler dans la cellule située immédiatement à droite. Ceci n'est possible que si la cellule de droite est vide, c'est à dire qu'elle ne contient pas elle-même du texte ou un nombre. Si la cellule de droite n'est pas vide, le texte ne pouvant s'étaler sera tronqué. Pour remédier à cet inconvénient, on peut évidemment modifier la largeur de la ligne. Mais cette solution risque à terme de rendre les tableaux trop larges pour être imprimés. On peut à ce moment là choisir d'étaler le texte de la cellule sur plusieurs lignes. Cette option s'obtient par l'intermédiaire du menu Format - cellule - onglet Alignement. Il est recommandé lorsqu'on utilise cette option d'utiliser le centrage horizontal et vertical du texte.

 

        

 

Exemple d'utilisation de la boîte de dialogue du menu Format - Position.

 

Sans mise en forme :

Prix unit

Quantités

Montant to

 

Avec renvoi à la ligne automatique :

Prix

 

Unitaire

 

 

Quantités

Montant

 

total

 

avec centrage horizontal et vertical :

Prix

 

Unitaire

 

Quantités

Montant

 

total

 

  

FORMULES DE CALCUL DANS EXCEL

 


 

Construction d'une formule

 Pour obtenir le stock final dans le tableau suivant, on peut effectuer un calcul manuel. Ce calcul sera le suivant :

15 + 8 - 4 = 19

 

Le nombre 19 ainsi obtenu sera inscrit dans la cellule D2.

 

 

Néanmoins, ce résultat ne se modifiera pas si l’un des nombres (15, 8 ou 4) est modifié. Pour automatiser ce calcul, on va construire une formule dans la cellule D2. Cette formule fera référence aux cellules contenant les nombres à utiliser et sera précédée du signe « = » pour qu’EXCEL comprenne qu’il s’agit d’une formule de calcul.

La formule sera donc la suivante :

 

=A2+B2-C2

Attention, cette formule ne doit comporter aucun espace entre les termes !

 

Les opérateurs utilisés dans les calculs se trouvent sur le pavé numérique du clavier et sont les suivants :

+      Addition

-        Soustraction

*       Multiplication

/        Division

Ù      Elever à la puissance

 

En l'absence de parenthèses, EXCEL calcule en premier les multiplications et divisions, et termine par les additions et soustractions. Si le calcul est présenté avec des parenthèses, EXCEL effectue en premier le calcul à l'intérieur de celle-ci avant de traiter les autres opérations

 

Exemple :                             2 X (3 + 4) = 14

                                               (2 X 3) + 4 = 10


 

 

Somme automatique

 Cette fonction permet d'obtenir automatiquement la somme d'une plage de cellules donnée.

 

1ère méthode

 

1)   Sélectionner la cellule qui contiendra le résultat du calcul (et donc la formule de calcul)

2)   Cliquer sur le bouton somme automatique de la barre d'outils

3)   Dans la barre de formule s'affiche :

 

=SOMME(Début de la sélection;Fin de la sélection)

 

Excel vous propose une plage de cellules par défaut. Il est possible d'en changer en sélectionnant la plage de cellules désirée à l'aide de la souris.

 

2ème méthode

 

1)   Sélectionner la cellule qui contiendra le résultat du calcul (et donc la formule de calcul) et étendre la sélection aux cellules qui doivent être additionnées.

2)   Cliquer sur le bouton somme automatique de la barre d'outils .

3)   Le résultat s’inscrit automatiquement.

 

La fonction Somme

 Pour additionner entre elles plusieurs cellules contiguës, on peut utiliser la fonction =SOMME() d’EXCEL.

 

1)   Ecrire dans la cellule où doit apparaître le résultat : =somme (

2)   Sélectionner ensuite à la souris la plage de cellules à additionner.

3)   Valider avec la touche Entrée

 

La fonction renvoie l’addition des sommes sélectionnées.

 

 

La fonction Moyenne

 Pour obtenir la moyenne de plusieurs cellules contiguës, on peut utiliser la fonction =MOYENNE() d’EXCEL.

 

1)   Ecrire dans la cellule où doit apparaître le résultat : =moyenne(

2)   Sélectionner ensuite à la souris la plage de cellules désirée

3)   Valider avec la touche Entrée.

 

La fonction renvoie la moyenne des sommes sélectionnées

 

La Fonction Logique "Si"

 On peut demander à Excel de réagir différemment en fonction du résultat d’un calcul demandé.

 

Exemple :

Vous décidez d’élaborer une facture. Vous souhaitez faire bénéficier à votre client d’une remise sur le prix de vente. Cette remise sera de 5% du total hors taxes de la facture si ce total inférieur à 1000 euros. Si le total hors taxes est supérieur ou égal à 1000 euros, le taux de la remise sera de 10% sur la totalité du montant.

Le document Excel se présentera ainsi :

 

 

La formule en D6, compare tout d’abord le résultat obtenu en D5 au nombre 1000.

Si le montant en D5 est plus petit que 1000, alors (symbolisé par le point virgule) le résultat à afficher en D6 sera celui du calcul : D5 multiplié par 5%.

Sinon (symbolisé par le deuxième point virgule) c’est à dire si le montant en D5 est égal ou plus grand que le nombre 1000, le résultat à afficher en D6 sera celui du calcul : D5 multiplié par 10 %

 

Formule "Arrondi"

 Le résultat d’une division ou d’une multiplication peut donner un nombre comportant plusieurs décimales. Dans le but de créer des formulaires destinés à des tiers (exemple facture) les nombres doivent, en principe, se présenter avec simplement deux décimales. On peut, bien entendu, utiliser le format des nombres. Mais Excel va conserver en mémoire le nombre initial avec plusieurs décimales et l’utilisera pour les calculs ultérieurs. D’où des problèmes d’affichages.

 

Exemple :

Le résultat du calcul : 2 divisé par 3 donne le résultat 0.666666666.....

Si on additionne 0.66666666.... avec 0.6666666.... on obtient 1.33333333.....

 

 

Avec un format des nombres à deux décimales, Excel propose un arrondi de présentation qui donnera : 0.67 + 0.67 = 1.33. Evidemment, cet arrondi de présentation n’est pas satisfaisant. Il faut donc utiliser une formule d’EXCEL, la formule =ARRONDI()

 

Cette formule requiert deux arguments :

 

le premier est le nombre à arrondir. Ce nombre peut également être remplacé par la référence à une cellule contenant un nombre. Il peut également être une formule de calcul complexe.

 

Le second représente le nombre de décimales que l’on souhaite obtenir.

 

On aura donc par exemple pour obtenir le résultat du calcul 2/3 arrondi à 2 décimales:

 

=ARRONDI(2/3;2)

 

Le résultat de cette formule sera 0.67. Ce nombre s’affichera directement dans la cellule sans que l’on ait besoin de passer par le format des nombres.



 

L’argument «nombre de décimales » donne des arrondis différents selon le chiffre utilisé. Voici un exemple des arrondis possibles du nombre 10734,12 :

 

 

=ARRONDI(10734,12;2)

10734.12

=ARRONDI(10734,12;1)

10734.1

=ARRONDI(10734,12;0)

10734

=ARRONDI(10734,12;-1)

10730

=ARRONDI(10734,12;-1,5)

10735

=ARRONDI(10734,12;-2)

10700

=ARRONDI(10734,12;-3)

11000

Etc.

 

 

 

Adresse Absolue

 Dans une formule de calcul il est fait référence, en général, à d'autres cellules. Par exemple, si l’on veut dans le tableau ci-dessous obtenir un prix après remise dans la cellule D6, on construit dans cette cellule la formule =C6*C3.

 

En fait, Excel raisonne sur les références de cellules  utilisées. Pour lui, C6 est la cellule qui se trouve sur la même ligne et dans la colonne de gauche par rapport à la cellule D6 où l’on a construit la formule. La référence utilisée est donc pour lui :

« LC(-1)» qui veut dire : même Ligne «L», une Colonne à gauche « C(-1) ». De même, la référence C3, est pour lui L(-3)C(-1) qui veut dire trois Lignes au-dessus «L(-3) », une Colonne à gauche «C(-1)»

 

Si l'on recopie cette formule sur les cellules D7 et D8, on va en fait recopier non pas  la formule=C6*C3, mais la formule =LC(-1)*L(-3)C(-1).

 

Le résultat obtenu n’est évidemment pas satisfaisant.

 

En effet, si l’on se place sur la cellule D8, on pourra lire dans la barre de formule le calcul suivant : =C8*C5. C8 est la cellule contenant le prix unitaire voulu, mais C5 ne contient pas le taux de remise mais un texte.

 

 Ceci s’est produit car  la formule recopiée en D8  est celle construite en D6, c’est à dire : LC(-1)*L(-3)C(-1).

 

Par rapport à D8, LC(-1) se trouve être la cellule C8. Cette référence est correcte. Mais, par rapport à D8, L(-3)C(-1) se trouve être la cellule C5. Or, la cellule contenant le taux de remise est la cellule C3. Notre calcul est donc faux.  On dit alors qu’Excel travaille en fonction de références relatives.

 

Si l'on veut que la référence à la cellule C3 demeure lors d’une recopie de la formule de calcul, il faut neutraliser ce principe de référence relative. Pour cela, lors de la construction de la formule =C6*C3, il faut demander à ce la référence C3 soit absolue

 

a)   Dans la barre de formule sélectionner C3

b)   Appuyer sur la touche F4

c)   Constater le résultat dans la barre de formule. On obtient  =C6*$C$3. La cellule C3 est devenue une référence absolue. Les symboles $ (dollars) vont figer la référence.

 

Si l’on recopie la formule vers le bas  en D7 et D8, on obtiendra :

            en D7 : =C7*$C$3

            en D8 : =C8*$C$3

Les symboles « $ » peuvent être également ajoutés au clavier.

 

Nommer des cellules

 Dans une formule on utilise, en principe, le nom par défaut des cellules (A1, H25, B14, etc.) il est possible de renommer les cellules. En reprenant l’exemple précédent, on peut renommer la cellule C3 afin de l’utiliser ensuite dans les calculs.

 

Par exemple, on va renommer la cellule C3 et lui donner le nom « Taux_remise ». Pour cela,

Ø      on sélectionne la cellule C3 (son nom apparaît dans la « zone nom » à gauche de la barre de formule),

Ø      on clique dans cette zone,

Ø      on écrit le nom désiré (attention, pas d’espaces ni de caractères spéciaux tels que : / , . ; etc.)

Ø      on valide avec la touche « Entrée »

  

Avant :

 Après :

A présent, toujours en reprenant l’exemple précédent, la formule de calcul pour la remise sera :

 

en D7 : C7*Taux_remise

 

Il est ensuite possible de recopier cette cellule vers le bas qui deviendra en D8 :

 

=C8*Taux_remise

 

La fonction Maximum

 Pour obtenir le plus grand nombre contenu dans des cellules différentes, on peut utiliser la fonction =MAX()  d’EXCEL.

 

1)   Ecrire dans la cellule où doit apparaître le résultat : =max(

2)   Sélectionner ensuite à la souris la plage de cellules (ou plusieurs plages de cellules en maintenant la touche Ctrl enfoncée) désirée.

3)   Valider avec la touche Entrée

 

la fonction renvoie la valeur la plus élevée

  

La fonction Minimum

 Pour obtenir le plus petit nombre contenu dans des cellules différentes, on peut utiliser la fonction =MIN() d’EXCEL.

 

1)   Ecrire dans la cellule où doit apparaître le résultat : =min(

2)   Sélectionner ensuite à la souris la plage de cellules (ou plusieurs plages de cellules en maintenant la touche Ctrl enfoncée) désirée.

3)   Valider avec la touche Entrée

 

la fonction renvoie la valeur la moins élevée

 

 

INSERTION, SUPPRESSION, DEPLACEMENT DE CELLULES

 

Insertion de cellules

 Exemple pour insérer une ligne entière :

 

1)   Sélectionner une cellule à l’endroit où la ligne entière doit être insérée.

2)   Choisir le menu  Insertion - ligne

 

EXCEL insère une ligne vide à partir de votre sélection. Il est bien entendu possible d’insérer simultanément plusieurs lignes. Il suffit pour cela de sélectionner plusieurs lignes avant d’utiliser le menu Insertion - ligne.

 

Exemple pour insérer une colonne entière :

 

1)   Sélectionner une cellule à l’endroit où la colonne entière doit être insérée.

2)   Choisir le menu  Insertion - colonne

 

EXCEL insère une colonne vide à partir de votre sélection. Il est bien entendu possible d’insérer simultanément plusieurs colonnes. Il suffit pour cela de sélectionner plusieurs colonnes avant d’utiliser le menu Insertion - colonne.

 

Exemple pour insérer une ou plusieurs cellules vides

 EXCEL insère le nombre de cellules sélectionnées à l’endroit de la sélection.

 1)   Sélectionner le nombre de cellules désiré à l’endroit désiré

2)   Choisir le menu Insertion - cellule.

3)   Une boîte de dialogue s’ouvre et vous propose de décaler les cellules sélectionnées afin de laisser la place aux cellules vides à insérer

·      soit vers la droite : les cellules sélectionnées seront décalées vers la droite

·      soit vers le bas : les cellules sélectionnées seront décalées vers le bas

 

Déplacement de Cellules

 pour déplacer une ou plusieurs cellules :

 

Méthode 1

 1)   Sélectionner la ou les cellules à déplacer et choisir le menu Edition - Couper.

2)   Sélectionner la cellule d’arrivée et choisir le menu Edition - Coller.

 

Méthode 2

 1)   Sélectionner la ou les cellules à déplacer.

2)   Amener le pointeur de la souris sur le bord inférieur de la sélection.

3)   Faire glisser la sélection à l’endroit désiré à l’aide de la souris en maintenant le bouton gauche enfoncé.

4)   Relâcher le bouton de la souris

 

Déplacement avec Insertion

 Pour permuter des lignes (ou des lignes) d’un tableau :

 

1)   Sélectionner la ou les cellules à déplacer et choisir le menu Edition - Couper

2)   Sélectionner la zone d’arrivée et choisir le menu Insertion - cellule coupée

  

Suppression de Cellules

 EXCEL supprime le nombre de cellules sélectionnées à l’endroit de la sélection.

 

Exemple pour supprimer une ligne entière :

 1)   Sélectionner une ligne entière (en cliquant sur le numéro de ligne)

2)   Choisir le menu Edition - Supprimer.

 

EXCEL supprime la ligne sélectionnée

 

Exemple pour supprimer une ou plusieurs cellules vides

 1)   Sélectionner le nombre de cellules désiré à l’endroit désiré

2)   Choisir le menu Edition - supprimer

3)   Une boîte de dialogue s’ouvre et vous propose de décaler les cellules se trouvant à droite et en dessous des cellules

·      soit vers la gauche : les cellules restantes seront décalées vers la gauche.

·      soit vers le haut : les cellules restantes seront décalées vers le haut.

 

L’IMPRESSION DANS EXCEL


 

L'aperçu avant impression

 Il est indispensable, avant d'imprimer, de vérifier l'aspect final du document que vous venez de créer. Cette vérification s'obtient à d'aide du menu Fichier - aperçu avant impression. L'écran suivant apparaît :

 

 

En haut de l'écran des boutons se substituent aux menus EXCEL. Ces boutons déclenchent les actions suivantes :

 

SUIV

Permet d'afficher la page suivante (si le document comporte plusieurs pages)

PREC

Permet d'afficher la page précédente (si le document comporte plusieurs pages)

ZOOM

Permet d'agrandir (ou réduire) l'image de l'aperçu

IMPRIMER

Correspond au menu Fichier – imprimer

PAGE

Correspond au menu Fichier - Mise en page

MARGES

Affiche les marges du document

FERMER

Ferme l'aperçu et revient à l'écran normal pour effectuer d'éventuelles modifications

 Le nombre total de pages, que comporte le document, s'affiche en bas à gauche de l'écran dans la barre d'état.

Le curseur est remplacé dans l'aperçu par une loupe. Cette loupe remplace le bouton ZOOM (voir plus haut). Pour agrandir une partie de l'aperçu, on amène le curseur à l'endroit désiré et on clique sur le bouton gauche de la souris. Pour revenir à l'aperçu normal, on clique de nouveau sur le bouton gauche de la souris. La loupe est plus précise que le bouton ZOOM.

 

Si l'aperçu ne s'avère pas concluant, il faut modifier le document (bouton FERMER) ou préparer la mise en page (bouton PAGE).

   

Mise en page

 La mise en page du document s'obtient à l'aide du bouton PAGE de l'aperçu ou du menu Fichier - mise en page. Dans les deux cas la boîte à onglets s’ouvre. Les différentes options sont les suivantes :

Mise en page - onglet Page

L’onglet page présente les paramétrages suivants :

 

 

Orientation

 Le document peut être orienté de deux façons au moment de l'impression :

·      En portrait, c'est à dire à la française, le papier sera lisible verticalement.

·      En paysage, c'est à dire à l'italienne, le papier sera lisible horizontalement.

Echelle

 Si la taille du tableau réalisée est trop importante ou au contraire trop petite, on peut à volonté, réduire ou agrandir celui-ci en modifiant la valeur par défaut (100%) dans la zone correspondante. Attention, il faut veiller à ne pas trop agrandir un tableau au risque de le voir s'imprimer sur deux pages. A vérifier dans l'aperçu avant impression

On dispose également d'un ajustement automatique d'un tableau trop grand aux dimensions de la feuille. On clique alors sur l'option "ajuster".

 

Mise en page - onglet Marges

 L’onglet page présente les paramétrages suivants :

 

 

Marges du document

 Les marges de la feuille représentent la zone dans laquelle le document sera imprimé. Plus les marges seront petites, plus l'espace réservé au document sera important. Les marges seront donc réduites dans le cas où le tableau à imprimer est d'une taille importante. Attention, les imprimantes exigent une marge minimale sur les quatre cotés de la feuille. Il faut donc éviter de mettre les marges à zéro. Attention également à ne pas recouvrir l’emplacement de l’en-tête et du pied de page éventuels (voir ci-dessous).

 

Marges d’en-tête et pied de page

 Les marges de d’en-tête et pied de page représentent la zone dans laquelle ceux-ci seront imprimés. Plus les marges seront petites, plus l'espace réservé à l’en-tête ou au pied de page sera faible. Les marges seront donc réduites dans le cas où les marges du document auront été elles-mêmes réduites. Attention, les imprimantes exigent une marge minimale sur les quatre cotés de la feuille. Il faut donc éviter de mettre les marges à zéro.

 

Centrage automatique 

Il est également possible de demander à EXCEL de centrer automatiquement le tableau à l'intérieur de la page (et plus précisément à l'intérieur des marges choisies, voir ci-dessus). Pour obtenir le centrage désiré, on clique sur l'option correspondante. Le centrage peut être demandé :

 ·      Horizontalement, c'est à dire par rapport aux bords droits et gauches de la feuille.

·      Verticalement, c'est à dire par rapports aux bords supérieurs et inférieurs de la feuille.

·      Soit les deux à la fois.

 L’aperçu disponible dans la boîte de dialogue permet de se rendre compte des ajustements opérés.

Mise en page - onglet En-tête/Pied de page

L’onglet page présente les paramétrages suivants :

 

 

En-tête et pied de page automatiques.

 L’en-tête et le pied de page possèdent des caractéristiques identiques et fonctionnent donc de la même façon. Le contenu de l'en-tête et du pied de page s'inscrira à l'intérieur des marges supérieures et inférieures. Il faut donc veiller à ce que ces marges ait une taille suffisante

 On dispose d’un certain nombre d’en-têtes ou pieds de pages préprogrammés que l’on obtient en déroulant la liste à l’aide de la flèche a droite de chaque zone.


En-tête et pieds de pages personnalisés

 Il est également possible de créer son propre en-tête ou pied de page en utilisant les boutons suivants :

En cliquant sur le bouton  ou  , on obtient la même boîte de dialogue :

 Chaque section fonctionne comme un traitement de texte. On peut saisir du texte dans la section de son choix. Le retour à la ligne s'obtient à l'aide de la touche Entrée.

 Sur le document, le texte saisi dans les sections se présentera comme suit : 

Section gauche

le texte est aligné sur le bord gauche de la feuille

Section centre

le texte est centré par rapport aux bords droit et gauche de la feuille

Section droite

le texte est aligné sur le bord gauche de la feuille

 Il est possible de modifier la police de caractères de tout ou partie du texte saisi dans les sections. Pour ce faire on sélectionne le texte désiré et on clique sur le bouton . La boîte de dialogue qui s'ouvre permet de choisir la police

Les autres boutons à disposition au dessus des sections permettent d'utiliser des variables, c'est à dire des codes qui permettront d'imprimer sur le documents des informations variables (numéro de la page imprimée, date du jour, nom du document, etc.). Ces codes sont les suivants : 

Bouton

Code utilisé

Résultat à l'impression

&[Page]

Numéro de la page imprimée

&[Pages]

Nombre total de page que comporte le document

&[Date]

Date du jour où le document est imprimé

&[Heure]

Heure à laquelle le document est imprimé

&[Chemin d'accès]&[Fichier]

Emplacement du fichier

&[Fichier]

Nom du document imprimé

&[Onglet]

Nom de la feuille imprimée

 

Insérer une image

 Ces codes peuvent être combinés avec du texte saisi au clavier. Par exemple :

 Pour obtenir, dans un document de deux pages, le texte "Page 1 sur 2" sur la première page et "Page 2 sur 2" sur la deuxième, on écrira dans la section désirée :

 Page &[Page] sur &[Pages]

Mise en page - Onglet Feuille

 

L’onglet page présente les paramétrages suivants :

 

 

Zone d’impression

 En cliquant dans cette zone pour y placer le curseur, on pourra ensuite définir à la souris la zone de la feuille de calcul que l’on désire voir s’imprimer. Cette fonction est utile pour exclure de l’impression une partie de votre feuille de calcul sans avoir à masquer les lignes ou colonnes non désirées (voir page 8). Attention, cette fonction n’est pas utilisable si on y accède par l’aperçu avant impression. Il faut donc accéder à cette boîte de dialogue par l’intermédiaire du menu Fichier - mise en page.

Impression des titres

 En cliquant dans cette zone pour y placer le curseur, on pourra ensuite définir à la souris les lignes ou colonnes de votre feuille de calcul qui devront être automatiquement répétées sur chaque début de page à l’impression (par exemple les en-têtes de lignes ou de colonne d’un tableau s’imprimant sur plusieurs pages). Attention, cette fonction n’est pas utilisable si on y accède par l’aperçu avant impression. Il faut donc accéder à cette boîte de dialogue par l’intermédiaire du menu Fichier - mise en page.

Quadrillage

 Le quadrillage fictif de la feuille de calcul ne s'imprime pas. Pour demander son impression, il faut cliquer sur l'option « quadrillage ».

 

Ordre des pages

Si on désire demander la numérotation des pages d'un document, le sens de l'impression aura une importance. Par défaut,  l'impression se fera verticalement c'est à dire vers le bas puis vers la droite :

 

 

On peut également choisir une impression qui commencera vers la droite puis vers le bas :

 

 


 

Impression

 L'impression s'obtient, soit à partir de l'aperçu avant impression en cliquant sur le bouton "IMPRIMER", soit par le menu Fichier - Imprimer. Dans les deux cas la boîte de dialogue suivante s'ouvre :

 

  Les renseignements importants sont les suivants :

Etendue

 Par défaut, tout le document sera imprimé. On possède néanmoins la possibilité de n'imprimer qu'une fourchette de pages sur la totalité. Dans ce cas on choisira l'option « Pages » en précisant le numéro de la première et de la dernière page à imprimer.

Impression

 Par défaut seule la feuille active sera imprimée, et ce, en totalité. Il est néanmoins possible de faire un autre choix :

 

·      Sélection : n’imprime que la plage de cellules préalablement définie à la souris avant de demander l’impression. Cette commande peut se substituer à la notion de zone d’impression

·      Feuilles sélectionnées : seront imprimées les feuilles dont les onglet auront été sélectionnés

·      Classeur entier : permet d’imprimer la totalité des feuilles du classeur.

Copies

 Par défaut, un seul exemplaire du document sera imprimé. Si on désire en imprimer davantage, on écrira le nombre désiré dans la zone "Copies"

 On dispose en outre d'un bouton « Mise en page  qui permet d'accéder à la boîte de dialogue correspondante, et d'une option "Aperçu" qui permettra, si on l'active en cliquant dessus, d'accéder à l'aperçu avant impression